Archive for the ‘WordPress’ category

YouTube.com y WordPress.com

marzo 29, 2006

Como era de esperarse, nuestro amigo Nauta no se iba a quedar tranquilo hasta poder insertar un video de YouTube.com en un blog alojado en WordPress.com. Y lo logró!!

Efectivamente. Al parecer los mismos de WordPress.com habían implemenatdo un TAG especial para insertar estos videitos:

[youtube=http://youtube.com/?v=XXXXXXXX]

Esto, según vemos en el mismo blog de WordPress.com y en varios más (Blog de Jesus, Vidablog, 512Megas), esta operativo desde enero de este año.

Anuncios

Probando un video YouTube.com en un POST

marzo 29, 2006

Como pueden ver….no se ve nada.  Por lo tanto, el uso de videos YouTube.com en WordPress solo será posible si tienes una version instalada desde cero, como lo tengo en mi blog personal y no en un servicio gratuito como este que tiene ciertas restricciones.  Al menos por ahora.

Gracias a nuestro amigo Nauta por la observación.

YouTube, WordPress 2 y XHTML

marzo 28, 2006

YouTube.com Aquí experimentando con el WordPress, intenté añadir un video de YouTube.com. Pero no cargaba en el preview. Revisé el código HTML y el código no estaba completo, el editor del WordPress lo había cortado. Obviamente tenía el WordPress con las opciones por defecto que incluyen el editor avanzado y el validador de XHTML. Primero a buscar algo de información sobre el tag OBJECT en XHTML: http://www.w3schools.com/tags/tag_object.asp. El problema estaba claro, ya no se debe usar EMBED y el WordPress lo eliminaba automáticamente. Pués bueno, a googlear. Y encontré que no era el único con este problema al colocar -o mejor dicho- intentar colocar estos videitos de YouTube.com. Seguía buscando y encontré un plugin para colocar estos videos: WordPress/YouTube Video Gallery Plugin. Bajé el plugin, lo instalé y a probar. Aparentemente el editor seguía comiendose el código. No lograba ver los videos. Ni modo, a buscar en Google otro rato. Y por fin encontré un web muy interesante, miniplug.tv donde corregían un error en el código generado por este plugin y obviamente recomendaban desactivar el editor avanzado y la validación de XHTML de WordPres. Así que a probar… Eureka!!! ahora si puedo ver el video en un post y sin necesidad del plugin. En este web de miniplug.tv explican que hay que reemplazar el codigo del plugin:

<object width=”425″ height=”350″> <param name=”movie” value=”http://www.youtube.com/v/XXXXXXXXXXX“> </param> <embed xsrc=”http://www.youtube.com/v/XXXXXXXXXXX” mce_src=”http://www.youtube.com/v/XXXXXXXXXXX” type=”application/x-shockwave-flash” width=”425″ height=”350″></embed> </object>

por este:

<object type=”application/x-shockwave-flash” style=”width:425px;height:350px” data=”http://www.youtube.com/v/XXXXXXXXXXX“> <param name=”movie” value=”http://www.youtube.com/v/XXXXXXXXXXX”> </object>

siendo XXXXXXXXXXX el ID del video. Pero con la sintaxis correcta y operativa ya no es necesario el plugin asi que a postear videos. Muchas gracias a los amigos de miniplug.tv